HREMMouse: About HREM Mouse

About HREM Mouse

1.2

Introduction

This plug-in provides a set of functions to use a mouse tool (HREM Mouse). You can find an example that will brefly shows how to use the functions provided by this plug-in.

When you click the HREM Mouse icon with ALT key down, the following dialog will appear. Here, you can change the color and size of the marker, and the font size of serial numbers. If you want, you can hide the serial numbers.

The GMS 1.x version uses Gatan's TrackerObject.dll that will be installed by a standard installation.
Please send any inquiry on this plug-in to us (HREM Research Inc) as indicated in "Contact Us" page, but not to Gatan.

Contents

Contact Us
Copyright Statements
Installation
How to Use
Quick Reference

Generated on Tue Oct 29 13:51:17 2013 for HREMMouse by doxygen 1.6.1


HREMMouse: Contact Us

Contact Us

General enquiries on the HREM Mouse should be sent to:

HREM Research Inc.
14-48 Matsukazedai
Higashimatsuyama
Saitama 355-0055
Japan
Phone: +81 493 35 3913
Fax: +81 493 35 3919
email: support@hremresearch.com
Website: http://www.hremresearch.com/


HREMMouse: Copyright Statements

Copyright Statements

© Copyright 2006-2008 HREM Research Inc.

All rights reserved. This manual is protected by international copyright laws and treaties. Unauthorized reproduction and distribution of this manual, or any portion of it, will be prosecuted to the maximum extent possible and may result in severe civil and criminal penalties.

DigitalMicrograph is a trade mark of Gatan Inc.

Acknowledgements: We are grateful to Gatan software term to support TrackerObject.dll plug-in.


HREMMouse: Installation

Installation

  1. Exit (Quit) DigitalMicrograph if it is launched.
  2. Copy HREMMouse.bmp and HREMMouse.gtk to DigitalMicrograph/PlugIns.

Please check "TrackerObject.dll" exists in DigitalMicrograph/PlugIns.


HREMMouse: Quick Reference

Quick Reference

Functions

HRICountMouseClickPoints()
HRIGetNthMouseClickPoint()
HRIDeleteMouseClickPoint()
HRIDeleteAllMouseClickPoints()


HREMMouse: How to Use

How to Use

The following short script explains how to use the functions provided by the HREM Mouse plug-in.

You can use two types of mouse clicks, one is marked by a square annotation with a simple mouse click (MouseClick) and the other is marked by a circle annotation with a mouse click when holding down the ALT key (MouseClick2).

When you click the HREM Mouse icon with ALT key down, the following dialog will appear. Here, you can change the color and size of the marker, and the font size of serial numbers. If you want, you can hide the serial numbers.

Note:
You can delete the mouse click point, when you click again the same point with the SHIFT key down.

Image  img     := GetFrontImage();
Number nClicks  = HRICountMouseClickPoints(img);
Number nClicks2 = HRICountMouseClickPoints(img, "MouseClick2");
Number nX, nY;
Number i;

Result("MouseClick:\n");
for ( i = 1; i <= nClicks; ++i ) {;
    HRIGetNthMouseClickPoint(img, i, nX, nY);
    Result("  "+i+":(X, Y)=("+nX+", "+nY+")\n");
}

Result("MouseClick2:\n");
for ( i = 1; i <= nClicks2; ++i ) {
    HRIGetNthMouseClickPoint(img, "MouseClick2", i, nX, nY);
    Result("  "+i+":(X, Y)=("+nX+", "+nY+")\n");
}


HREMMouse: File Index

File List

Here is a list of all documented files with brief descriptions:
Functions.s


HREMMouse: Functions.s File Reference

Functions.s File Reference

Functions

number | HRICountMouseClickPoints (image source, string mouseLabel="MouseClick")
Count Mouse Click Points.
number | HRIGetNthMouseClickPoint (image source, string mouseLabel="MouseClick", number point, number &x, number &y)
Get Nth Mouse Click Point.
void | HRIDeleteMouseClickPoint (image source, string mouseLabel="MouseClick", number x, number y)
Delete A Mouse Click Point.
void | HRIDeleteAllMouseClickPoints (image source, string mouseLabel="MouseClick")
Delete All Mouse Click Points.

Detailed Description

Function Documentation

number HRICountMouseClickPoints | ( | image | source,
 |  | string | mouseLabel = "MouseClick"
 | ) |  |

Count Mouse Click Points.

Parameters:
source Image with mouse click(s)
mouseLabel Mouse point type. This parameter can be omitted. Default is "MouseClick".
Use "MouseClick" for a simple click, and "MouseClick2" a click with the ALT key down.
Returns:
Number of mouse click points
number HRIGetNthMouseClickPoint | ( | image | source,
 |  | string | mouseLabel = "MouseClick",
 |  | number | point,
 |  | number & | x,
 |  | number & | y
 | ) |  |

Get Nth Mouse Click Point.

Parameters:
source | Image with mouse click(s)
mouseLabel Mouse point type. This parameter can be omitted. Default is "MouseClick".
Use "MouseClick" for a simple click, and "MouseClick2" a click with the ALT key down.
point | Index of a mouse point
x | X coordinate of the point-th mouse point
y | Y coordinate of the point-th mouse point
Return values:
0 | failed
1 | found the point
void HRIDeleteMouseClickPoint | ( | image | source,
 |  | string | mouseLabel = "MouseClick",
 |  | number | x,
 |  | number | y
 | ) |  |

Delete A Mouse Click Point.

Parameters:
source | Image with mouse click(s)
mouseLabel Mouse point type. This parameter can be omitted. Default is "MouseClick".
Use "MouseClick" for a simple click, and "MouseClick2" a click with the ALT key down.
x | X coordinate of a mouse point to be deleted
y | Y coordinate of a mouse point to be deleted
void HRIDeleteAllMouseClickPoints | ( | image | source,
 |  | string | mouseLabel = "MouseClick"
 | ) |  |

Delete All Mouse Click Points.

Parameters:
source Image with mouse click(s)
mouseLabel Mouse point type. This parameter can be omitted. Default is "MouseClick".
Use "MouseClick" for a simple click, and "MouseClick2" a click with the ALT key down.


HREMMouse: Data Fields

  • All
  • Functions
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:
  • HRICountMouseClickPoints() : Functions.s
  • HRIDeleteAllMouseClickPoints() : Functions.s
  • HRIDeleteMouseClickPoint() : Functions.s
  • HRIGetNthMouseClickPoint() : Functions.s


HREMMouse: Data Fields

  • All
  • Functions
  • HRICountMouseClickPoints() : Functions.s
  • HRIDeleteAllMouseClickPoints() : Functions.s
  • HRIDeleteMouseClickPoint() : Functions.s
  • HRIGetNthMouseClickPoint() : Functions.s


HREMMouse: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Contact Us
  • Copyright Statements
  • Installation
  • Quick Reference
  • How to Use