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Getting Started 
 

In this chapter  
we explain the concept of xHREM™ 

and how to install them. 
Then, you will learn how to use xHREM™ 

by using the attached examples.  
 
 

! Introduction 
�

High Resolution Electron Microscopy (HREM) becomes an indispensable tool 
for understanding material properties or evaluating new materials at the level of 
atomic resolution.  Due to increased demands for research and development of 
the new materials, an image simulation acquires more importance than ever 
before. 

xHREM™ (WinHREM™/MacHREM™)� is a suite of the high-resolution 
electron microscope image simulation programs that will run on Windows or 
Mac OS.   
�

Concept of xHREM™ 
1. User Friendly Graphical Interface 

xHREM™ employs user friendly Data Generation Utilities based on the 
Graphical User Interface for Windows or Mac OS. 

xHREM™ is general-purpose software that can be used to simulate all 
the images expected from any crystal systems, defect structures and 
interfaces.  Although data generation for such general-purpose software 
normally becomes complex, a novice user can easily generate his/her data 
by using the graphical Data Generation Utilities with minimum 
requirements for the special knowledge.   

 

2. Reliable and Efficient Algorithm
Since electron microscope images critically depend on an 

electron-specimen interaction as well as aberrations of image forming lenses, 
the treatment of scattering based on dynamical theory and the treatment of 
aberration based on wave-optical theory are mandatory.  

xHREM™ emerges from the HREM image simulation programs based 
on FFT multislice technique developed at Arizona State University, USA 
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(see References).  This is one of the most reliable and efficient HREM 
image simulation programs.  

�

3. High Quality Image Output 
Numerical data such as projected potential, wave function propagating the 

specimen, simulated image intensities could printed as high quality gray 
scale maps (Bitmap) by using Output Graphic Utilities.  Numerical value 
of each pixel of the gray scale can be exported for further analysis with 
other software. 

  
Features of xHREM ™ 

" Efficient algorithm based on Fast Fourier Transform (FFT) 
" Applicable to any crystal systems and symmetries for an arbitrary 

beam direction 
" Applicable to defects, interfaces and artificial supper-lattices 
" Treatment of partial coherency based on the transmission 

cross-coefficient 
" Coherent Convergent Beam Electron Diffraction (Option) 
" High resolution STEM image simulation including HAADF-STEM 

images (Option) 
�

Steps for Image Simulation with xHREM™ 
xHREM™ consists of three graphical user interfaces (GUI) for scattering 

calculation, image intensity calculation and scattering intensity output.  
There are also other utilities for half-tone (gray-scale) image outputs.  
Even a novice user can easily generate input data satisfying the format 
required by the calculation programs, and then execute calculations.  High 
quality simulated images are easily obtained by using the gray-scale output 
utilities. 

Each GUI uses a window, called WORKSHEET, to assist the user to fill out 
the necessary data.  When saving (Save or Save As…) the input data in the 
WORKSHEET, the GUI converts the WORKSHEET data into the input 
data required by the calculation program.  Actual calculation is easily 
performed from the menu command (Execute) by using the converted data.   

 

To get gray-scale microscope images do the followings: 

1. Generate a required data for scattering calculation by using the 
graphical user interface called MultiGUI, and then perform 
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calculation from Execute command of the File menu.  
2. Generate a required data for image calculation by using the 

graphical user interface called ImageGUI, and then perform 
calculation from Execute command of the File menu. 

3. Obtain gray-scale images from the calculated images by using 
the utility called ImageBMP.  The output gray-scale images may 
be arranged into a table layout (Image Tableau) as functions of 
thickness and defocus.

References 
K. Ishizuka and N. Uyeda: A New Theoretical and Practical Approach to the Multislice Method, 
Acta Cryst. A33 (1977) 740-749. 

K. Ishizuka: Contrast Transfer of Crystal Images in TEM, Ultramicroscopy 5 (1980) 55-65 

K. Ishizuka: Multislice Formula for Inclined Illumination, Acta Cryst. A38 (1982) 773-779. 

K. Ishizuka: A practical approach for STEM image simulation based on the FFT multislice 
method, Ultramicroscopy 90 (2001) 71-83. 

 

�

�

! Before using xHREM™ 
 

If you are not familiar with routine operations of Windows/Mac OS such as 
a clicking, double-clicking or dragging the mouse, a menu selection, a file 
open/close procedure and so on, please consult the user's manual come with 
your computer for getting acquainted with Window GUI before using 
xHREM™. 
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! Installation 
 
Installing WinHREM 

WinHREM™ is distributed in CD-ROM or on-line.  The software should 
be installed into the hard disk by following the standard procedure. 

Insert the CD-ROM into the CD drive, or unzip a download file. Open the 
WinHREM 3.0 folder and execute manually by double-clicking the 
'Setup.exe' files.  It is advised that the WinHREM programs are installed 
into the directory named 'xHREM' under ¥Program Files¥HREM Research 
as instructed by the installer.  

The structure of the 'xHREM' folder on the hard disk will be the one shown 
below. Sample data will be installed in the 'xHREM Data' folder under your 
¥My Documents directory. 

The installer will register WinHREM application icons (shortcuts) under 
'xHREM' on the Start menu. 

 
Installing MacHREM 

MacHREM™ is distributed in CD-ROM or on-line.  The software should 
be installed into the hard disk by following the standard procedure. 

Insert the CD or open a disk image file that you have downloaded. Then, 
simply drag-and-drop the application folder (xHREM(E) (English) or 
xHREM(J) (Japanese)) onto the 'Applications' icon to copy it into the 
Applications folder, and drag the data folder (xHREM Data) onto 
Documents.app icon to copy it into the Documents folder. Also, please copy 
the 'Quesa.framework' folder into the 'Frameworks folder.' 

 
The structure of xHREM program folder 

Utilities : GUI, Output Utilities 
Programs : Programs for numerical calculation  
Resources : Resources used by Utilities 
Documents : Manuals 
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(Windows) Installing User Key Driver  

Installing User Key Driver
NOTE: Disconnect the USB key�
Launch “HASPUserSetup.exe,” and follow the instructions to install the user 
key driver. 

Installing User Key  
Simply plug your USB key into an USB port.   

If your user key is not recognized, the software will run as a demonstration 
version.  

 
 
(Mac OS) Installing User Key Driver 

Installing User Key Driver
NOTE: Disconnect the USB key�
Open the disk image file “HDD_Installer_MacOSX.dmg,” and launch “Install 
HASP USB Driver,” and follow the instructions to install the user key driver.

Installing User Key
Simply plug your USB key into an USB port.   

If your user key is not recognized, the software will run as a demonstration 
version.  
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! Let's Start Tutorials 
 
How to use GUI for Data Input 

By using three graphic user interfaces (GUIs), the required data for numerical 
calculations are prepared by filling the window called WORKSHEET.  Each GUI 
has File, Edit and Help menus.  Please consult the references for the details of 
each menu.���

 

Example Data
Two sets of data are provided within the Data folder for exercises.  They 
are a tin oxide (SnO2) and a complex oxide of tungsten and niobium 
(W8Nb18O89), and their sample name are SnO2 and WNbO, respectively.  
We use SnO2 here as an example, but the same steps can be applied to 
WNbO.  Please play with WnbO by yourself later. 

At first we calculate scatting amplitudes, and then calculate image 
intensities.  The gray-scale images or diffraction patterns will be obtained 
from the image intensities of the scatting amplitudes. 

 
 
 

Scattering Amplitude calculation 
At first, let's prepare the data required for the scatting amplitude calculation: 
1. Launch MultiGUI. 

Please consult your computer manual about how to launch an 
application. 

2. Select SnO2.WS1 from the Data folder, when the open dialog appears.  

Please consult your computer manual about how to select a file. 
The WORKSHEET for data input will appear. 
TIPS: The lower part of the WORKSHEET can be accessed by sliding 
the window or by expanding the display area.  
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In this WORKSHEET, appropriate data is already filled out.  Here, 
let's create a new data set by changing the Title entry: 

3. Input a new title "SnO2 test calculation" in the Title field.  
4. Choose "Save As..." from the File menu.  
5. Save the new data as "SnO2test" in the save dialog appeared.  

Please consult your computer manual about how to save your file.  
TIPS: An extension '.WS1' will be added automatically.  Thus, you 
may not need to specify the extension.  

 

Next, we calculate the scattering amplitudes by using the data crested above:  
6. Choose 'Execute Multislice' from File menu.  
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The program (multi.exe) that calculates the scattering amplitudes will 
be launched, and the progress of calculation will be displayed on a 
separate window.  When an execution terminates normally, you will 
see the message "Execution completed. Congratulations!" 
 

NOTE: The progress window has the fundamental menus such as File 
and Edit, and you can Save the content of the window from the File 
menu. 
TIPS: The program can be terminated even in the middle of calculation 
by Exit command from the File menu or clicking the close button. 
The progress window can be closed by Exit command from the File 
menu or clicking the close. 

7. To terminate MultiGUI, select 'Exit(Quit)' from the File menu.  
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Image Intensity Calculation 
The process for the image intensity calculation is similar with the scattering 
amplitude calculation.  Before this step, you must prepare the scattering 
data by using MultiGUI. 
1. Launch ImageGUI.  

2. Select SnO2.WS2 from the Data folder, when the open dialog appears.

Please consult your computer manual about how to select a file. 
NOTE: There is no WS2 file corresponding to the data name that we 
have used for the MultiGUI, namely SnO2test.WS2.  We will create it 
from now using an existing data (SnO2.WS2).  You may create a WS3 
data from a scratch by using Default.WS2. 
TIPS: The lower part of the WORKSHEET can be accessed by sliding 
the window or by expanding the display area. 

 

In this WORKSHEET, appropriate data is already filled out.  Here, 
let's create a new data set by changing the Title entry: 

3. Input a new title "SnO2 test calculation" in the Title field.
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4. Choose "Save As..." from the File menu.

5. Save the new data as "SnO2test" in the save dialog appeared.

TIPS  An extension '.WS2' will be added automatically.  Thus, you 
may not need to specify the extension. 

 

Next, we calculate the image intensities by using the data crested above:�
6. Choose 'Execute' from File menu.

The program (Image.exe) that calculates the image intensities will be 
launched, and the progress of calculation will be displayed on a separate 
window.  When an execution terminates normally, you will see the 
message "Execution completed. Congratulations!"  

NOTE: The progress window has the fundamental menus such as File 
and Edit, and you can Save the content of the window from the File 
menu. 
TIPS: The program can be terminated even in the middle of calculation 
by Exit command from the File menu or clicking the close button. 
The progress window can be closed by Exit command from the File 
menu or clicking the close. 

7. To terminate ImageGUI, select 'Exit(Quit)' from the File menu.
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EM Image Display 
Then, let's display gray-scale (half-tone) images that have been numerically 
calculated for SnO2 by using ImageGUI. 

At first, you have to launch a utility and select a numerical image data to be 
displayed: 
1. Launch ImageBMP. 
2. A data selection dialog will be opened.  Select SnO2test.AUX in the Data 

folder.  (A data file for image display has ".AUX".) 

The following window will be appeared. 

 

Then, let's get some images. 
3. Click "Generate" in the right bottom of WORKSHEET.  

After a few seconds, you may get a gray-scale image shown below.  
This is an image calculated for the conditions corresponding to a slice 
and a defocus specified in the WORKSHEET.  Specifically, Slice: 10; 
Defocus: 500 A (under-focus); Display Range: (0<->1) x (0<->1). 
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Next, draw a wider gray-scale image extended over a few unit cells.  
4. Change end-points (left input-boxes) of a and b of "Display Range" to two (2). 
5. Click "Generate" as before. 

You will get a gray-scale image of 2 x 2 unit cells as shown below.   
 

 
 

6. You can save each gray-scale image by choosing "Save" or "Save As…"  
from "File" menu, if you want to.  

You can choose an image format in the dialog that will appear.  
If you want to save a quantitative data (binary data) of the displayed 
image, you can use "Export Data…" command (Please refer to 
Topics/Numarical Data Output using ImageBMP).  
You can also print each gray scale image by choosing "Print" from 
"File" menu.  

7. Close each Bitmap window by choosing "Close" from "File" menu.  

If the gray-scale image has never been saved, a dialog for confirming 
your action.  
TIPS: You can avoid this confirmation dialog, when you close the 
window while pressing the "Shift" key.  

8. To terminate ImageBMP, select "Exit (Quit)" from "File" menu.  

NOTE: The default file name of an EM image is "Sample name_slice 
number_defocus.bmp." 
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To obtain an image at other slice and/or defocus, select a slice number 
and/or defocus value from the "Slice" and "Defocus" pull-down menus.  
These pull-down menus show all possible selections on your data set.  

 

When you choose “Select” from “Slice” or “Defocus” pull-down menu, you 
will get a following dialog, where you can select the slices or defocuses that 
you want to display. 

 

TIPS:��If you choose "All" or “Select” from "Slice" or “Defocus” pull-down 
menu, EM images for all, or selected slices or defocus values will be 
displayed in sequence. 

TIPS:��If you choose "All" or “Select” both from "Slice" and "Defocus” 
pull-down menus, EM images for combinations of all, or selected slices and 
defocus values will be displayed in sequence. 

TIPS:��If you click “Image Tableau” check box, the selected images will be 
displayed in a table layout in terms of Slice numbers and Defocus values.  
In the example below, all the calculated images were displayed.  You can 
specify the way of layout of slices and defocuses as well as gaps between 
each image in the dialog that will appear when you click “Options” button 
(see Application section for more details).  



xHREM Userʼs Guide 17 

 

TIPS:�If you select “Atom Overlay” check box, a colored circle specific for 
each element will be drawn at each atom position as shown below.  The 
size of the circle and its color will be modified with a dialog that will appear 
when you click “Setup" button.  

 
NOTE:�The gray-scale image can be printed out by using "Print" from "File" 
menu.  The displayable gray levels depend on your printer specifications.  �
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Diffraction Spot Pattern Display
Here, let's display electron diffraction patterns for SnO2 by using calculated 
scattering data with MultiGUI.  

At first, you have to launch a utility and select a scattering data to be 
displayed:�
1. Launch SpotBMP.  

2. A data selection dialog will be opened.  Select SnO2test.DF in the Data folder.  
(A data file for image display has ".DF".)

A WORKSHEET for setting up display conditions will be appeared. 

�

Then, let's get some diffraction patterns.�
3. After setting the condition as shown above, click "Generate" in the right bottom 

of WORKSHEET. 

After a few seconds, you may get a gray-scale image shown below. 
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4. Next, uncheck the "Show Index" and select "Peak" from the "Spot Shape," 

then Click "Generate. " 

After a few seconds, you may get a gray-scale image shown below. 

 
5. To terminate SpotBMP, select "Exit (Quit)" from "File" menu. 
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! Topics 
 

In this section some useful functions as well as advanced topics will be 
introduced.  It is not necessary to read through all the topics at the first time.  
You may want to study each topic when you need to use it.  
 

Display Model Potentials or Wave-functions  
Model potential distributions or wave-functions within the sample, which 
were calculated with MultiGUI (multi.exe), will be displayed as gray-level 
images by using ImageBMP.  

To display them:  
1. Execute a calculation with a check on corresponding “Export Data for Gray 

Scale Map” in the “Output Control” section of MultiGUI. 

The display data will be saved in a file with “.AUX” extension.  
NOTE: The file with the same extension is also used by ImageGUI to 
save microscope image data.  Therefore, if you want to keep the data 
for later use, you have to change the AUX file name to a unique name 
keeping the same extension.  

2. Launch ImageBMP, and select a corresponding AUX file.  

The following window, which you have seen for microscope image 
display, will be open.  However, the “Image Selection” section is 
different from that for the microscope images, since the potential 
distributions and the wave-functions are saves as complex numbers.  
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3. Setup display conditions and select what you want to display. 
Potential: You can specify a slice number (from 0 to 9) to be displayed, when 
you have divided a unit cell into different slices up to ten (10). 
Wave Function: Select a thickness (in slice number) to be displayed. 
Show: Since the potential distributions and the wave-functions are saves as 
complex numbers, you have to select a quantity to be displayed from the 
following list: 

 
4. Click “Generate” to create a gray scale image.  
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Survey Diffraction Intensity  
You can qualitatively compare dynamical diffraction intensities by looking 
a gray scale display generated by SpotBMP.  When you want to compare 
the intensity quantitatively, you can use “DFOutGUI.”  

To survey diffraction intensities (amplitudes), you have to prepare the data 
as follows: 
1. Launch DFOutGUI.  

2. Select SnO2.WS3 from the Data folder, when the open dialog appears.

NOTE: There is no WS3 file corresponding to the data name that we 
have used for the MultiGUI, namely SnO2test.WS3.  We will create it 
from now using an existing data.  You may create a WS3 data from a 
scratch by using Default.WS3. 
The following WORKSHEET will appear.  

 

In this WORKSHEET, appropriate data is already filled out.  Some 
reflection indexes are already specified for each page.  Here, let's use 
this data as it is. 

3. Choose "Save As..." from the File menu.
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4. Save the new data as "SnO2test" in the save dialog appeared.

TIPS: An extension '.WS3' will be added automatically.  Thus, you 
may not need to specify the extension. 

 

Next, we survey the image intensities by using the data saved above: 
5. Choose 'Execute' from File menu.

The program (DFOut.exe) that lists/displays the diffraction intensities 
will be launched, and the numerical lists and graphs for specified 
reflections will be displayed on a separate window.  When an 
execution terminates normally, you will see the message "Execution 
completed. Congratulations!"  

The amplitude is displayed as a normalized value relative to an incident 
wave (Normalized), or as a scaled value relative to kinematical 
scattering amplitude (Kinematical scale). 
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TIPS: The kinematical structure factors (scattering amplitudes) used in 
potential calculation will be displayed, when you set a starting slice to 
zero in “Output Range” section. 
In the graphic chart the magnitude of amplitude is displayed in log scale 
to display a wide range of data.  On the other hand the phase is 
displayed between [-!, +!].  You may note that this phase is shifted by 
!/2 to be consistent with the phase of kinematical structure factor. 

 

NOTE: The progress window has the fundamental menus such as File 
and Edit, and you can Save the content of the window from the File 
menu. 
TIPS: The program can be terminated even in the middle of calculation 
by Exit command from the File menu or clicking the close button. 
The progress window can be closed by Exit command from the File 
menu or clicking the close. 

6. To terminate DFOutGUI, select 'Exit(Quit)' from the File menu.
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Survey image Intensity 
Electron micrograph images or wave-functions displayed by using 
ImageBMP will be surveyed quantitatively as explained below.  Intensity 
profile along the specified line drawn on the image can be displayed and 
surveyed quantitatively.   

Intensity on a gray scale image:  When you move the mouse over a gray 
scale image created by ImageBMP, intensity under a mouse point is 
displayed at the lower part of window with its coordinates.   

 
NOTE: An intensity value will not be displayed for an image created as 
an “Image Tableau.”  

Profile image: When you place a mouse on a starting point of a profile, and 
drag a mouse with SHIFT key down, a red line is drawn on the image.  
When you stop dragging, intensity under the red line is displayed on a 
separate window 
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When you put a mouse on a line of the profile window, intensity and its 
original image coordinates are displayed below the profile. 

NOTE: A profile image will not be displayed for an image created as 
an “Image Tableau.”  
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3D Display of Atomic Model 
Using a 3D display you can check your atomic model to be used by 
MultiGUI.  Here, we explain the 3D display by using a sample data of 
SnO2.  

To display an atomic model as a 3D image:  
1. Launch MultiGUI. 
2. A data selection dialog will be opened.  Select SnO2.SW1 in the Data folder.   

The WORKSHEET for SnO2 will be appeared. 
3. Click “Model View” in the Option section at the very bottom of the 

WORKSHEET. 
 

 

TIPS: The lower part of the WORKSHEET can be accessed by sliding 
the window or by expanding the display area.  
 

Then, you will get a 3D display of the Atomic model: 
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Under the regular setting the model is displayed as a projection along c-axis.  
The direction of projection is easily changed by selecting “a, b or c” in the 
tool bar. 
TIPS: Tools in the tool bar (left to right): Rotation, Back and forth 
movement, In-plane movement, Projection directions, Perspective control.  

By adjusting a slider of the “Projection control” the model is displayed in 
perspective drawing.   The following show an example. 
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Including TDS Absorption 
You can include absorption of elastically scattered wave due to thermal 
diffuse scattering (TDS) in your dynamical calculation.  In this case, 
however, thermal displacement parameter (temperature factor; 
Debye-Waller factor) for each atom in your atomic model is required.  
When you don’t know a corresponding parameter, an approximate value 
may be specified.  

To include TDS absorption in your dynamical calculation: 

１． Launch MultiGUI 

２． Choose “Preferences” from Edit menu. 

３． Select “Weikenmeier-Kohl Scattering Factor” in “Atomic Scattering Factor” 
section of the Preferences dialog, and check “Include TDS absorption.” 

 

４． Setup other parameters and execute “Multislice.” 
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Data Sharing using CIF File 
xHREM ™  can read/write (Import/Export) a data with CIF 
(Crystallographic Information File) format.  Therefore, you can share 
crystal data (lattice constants, Space group/Symmetry operations, Atomic 
positions etc.) with other software.   

 

NOTE: The CIF data items handled by xHREM™ : Lattice constants, 
Space group (Symmetry operations), Atom species, Atom coordinates, 
Thermal factor, Occupancy.  

xHREM for Windows and Mac OS stores atomic model data such as atomic 
positions with the same database format. Therefore, the atomic model 
database can be freely shared between Windows and Mac OS.  

NOTE: You can also share an atomic model data with other 
applications by saving them as a text file using “Export” button on the 
“Edit” window of “Atom Parameters” section of MultiGUI.  
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Permutation of Crystal Axes 
xHREM™  can take account of an incident surface effect into dynamical 
calculation (K. Ishizuka: Multislice Formula for Inclined Illumination: Acta 
Cryst. A38 (1982) 773-779).  Therefore, an incident beam direction of 
<hk0> that is parallel to the surface is forbidden.  

However, when you neglect the incident surface effect (most of the 
programs do not take into account the surface effect), you can 
straightforwardly calculate for <hk0> incidence by using a capability of 
permutation of crystal axes without changing a model data.   

To permute the crystal axes, choose “Preferences” from Edit menu of 
MultiGUI.  Then, you may notice “Crystal Setting” on the upper right of 
the Preferences window as shown below: 

 

For example, in the case of <110> incidence we cannot use I (a.b.c) system, 
since the index of the third axis (c-axis) is zero.  However, indexes of both 
a-axis and b-axis are not zero, and thus we can use either these axes for the 
third axis.  Therefore, we can choose one system from II, III, V or VI for 
the <110> incidence.  Contrary to this, in the case of <100> both indexes 
of b- and c-axes are zero, and thus we cannot use both of them as the third 
axis.  Therefore, we can use either II or V system where a-axis is the third 
axis.   

NOTE: Neither the crystal axes nor symmetry operations are permuted 
in the WORKSHEET of MultiGUI.  Nevertheless, the selected crystal 
system is used in calculation, and symmetry operations are transformed 
accordingly.  When you check the list output, you can verify the lattice 
constants, atom parameters, and symmetry operations actually used in 
calculation.   
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Calculation of Static Diffuse Scattering 
Since xHREM™  can handle up to 100,000 atoms, diffuse scattering due to 
static disorder of atom positions can be estimated by using an atomic model 
including static displacements of atom positions.  

To calculate diffuse scattering due to static disorder: 
1. Launch MultiGUI.

2. Input necessary data in the WORKSHEET as usual.

Using “Edit” dialog of “Atom Parameters” of MultiGUI, it may be 
difficult to prepare a large atomic model including static displacements 
of atom positions.  Therefore, it may be convenient to read a text data 
file of atomic model created separately by using “Import” capability.  

3. Click “DIFFUSE” in the Option section at the very bottom of the WORKSHEET. 

 

TIPS: The lower part of the WORKSHEET can be accessed by sliding 
the window or by expanding the display area.  
The following dialog will appear, where you can specify some output 
controls specific to DIFFUSE calculation.  Change controls as you 
want, and Click “OK.” 

 
4. Save your data. 
5. Choose “Execute DIFFUSE” from File menu. 
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The program (diffuse.exe) that calculates the diffuse scattering 
amplitudes will be launched, and the progress of calculation will be 
displayed on a separate window.  When an execution terminates 
normally, you will see the message “Execution completed. 
Congratulations!” 
NOTE: The progress window has the fundamental menus such as File 
and Edit, and you can Save the content of the window from the File 
menu. 
TIPS: The program can be terminated even in the middle of calculation 
by Exit command from the File menu or clicking the close button. 
The progress window can be closed by Exit command from the File 
menu or clicking the close. 

6. To terminate MultiGUI, select "Exit (Quit)" from "File" menu.  
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Display Diffuse Scattering Distribution 

“ImageBMP” can be used to display diffuse scattering distributions.  
Diffuse scattering data is saved in a file with “.ED” extension.  

To display diffuse scattering patterns: 
1. Launch ImageBMP. 
2. Open a “.ED” file with an appropriate name. 
3. Setup display controls.

According to “ImageBMP” instructions setup an image display area, the 
resolution and so on, and select a thickness in slice number to display 
scattering pattern.   
Since a scattering data is save as complex numbers, a data type to be 
displayed will be selected from “Show” list.   

4. Click “Generate” to display a gray scale map. 
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Numerical Data Output Using ImageBMP 

“ImageBMP” displays a gray scale image of various data as a Bitmap.  A 
numerical value of each pixel of the gray scale map can be output for further 
analysis with other application, such as Gatan’s DigitalMicrograph. A 
numerical data used to generate the gray scale map can also so be output. 

The file menu of ImageBMP and the image display windows have “Export 
Data…” command as shown below: 

 
A numerical data used to generate the gray scale map can be output using 
the “Export Data…” command of ImageBMP. 

A numerical value of each pixel of the gray scale map can be output using 
the “Export Data…” command of each image display window. 

Output data format: 

The following data format(s) will appear in the “Save as type” list in 
the Save As dialog according to whether the output data is real or 
complex numbers.  

Real data 
TIFF output: TIFF format (.tif) 
Binary output: Portable Floatmap File (.pfm) 
Text output: Comma Separated Values File (.csv) 

Complex data Binary output: Portable Complexmap File (.pcm) 
TIFF output: TIFF format (.tif) 

NOTE  Portable Floatmap File (.pfm) or Portable Complexmap File 
(.pcm) format is a Binary data format that has a text header. xHREM 
uses a header of 192 bytes. The text header includes information on an 
image size. 
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Application 
 

In this chapter  
we explain how to create your own data, 

and the way to customize xHREM™  
by using Preferences and Templates. 

Then, you will see a detailed explanation for each data item  
of the Graphical User Interfaces.  

 
 

! Let's attack a problem in hand 
 

Before proceed to this chapter, please get acquaintance with xHREM by 
going through the examples of the "Getting Started."   In this chapter, you 
will learn how to create a new data for your own problem, and then how to 
display your results and more…  

 

Steps to create a New Data  
There are two ways to create a new data for your application:  
" Update an existing data  
" Create a data from scratch  

�

To create a new data from an existing data, do this: 
1. Launch a corresponding graphical user interface (GUI). 
2. Select an existing data you want to copy in the file selection dialog.  

The WORKSHEET will appear with data you select.  

3. Save this data with a new name by choosing "Save As…" from File menu.  

NOTE This step is strongly recommended not to lose the existing data by an 
accidental overwrite.  
4. Then, change data as you want. 
5. When finished, save your modified again data by choosing "Save" from File 

menu.  

�

To create a new data from a scratch, do this:��
1. Launch a corresponding graphical user interface (GUI). 
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2. Select "Default" from the file selection dialog.  
The WORKSHEET named "Untitled" will appear with some default 
data.  

3. Fill out your data in the WORKSHEET.  
4. When finished, save your data with a new name by choosing "Save As…" 

from File menu.  
�

�

Setting up Preferences 
The calculation programs (Solvers) only accept the data with a definite 
format and units.  However, you may want to use other units in your 
WORKSHEET.  You can choose your preferred units for your input in 
"Preferences" window.  Moreover, the Preferences hold some control data 
that does not depend on each sample, in order to save your trouble to input 
these data at each time.��

To set up the Preferences:  
1. Choose "Preferences" from "Edit" menu of MultiGUI or ImageGUI.  

The following "Preferences" window will open. 
TIPS:  The first choice of Units or Defocus sign is used in the calculation 

program.  The data specified in other units will be converted by the 
graphical user interface (GUI).��

2. Change settings according to your preference.  
"Apply" will change the WORKSHEET according to the change(s).  

3. Click "Close" or “Cancel” to close the Preferences window.  
When “Close” is clicked, the current settings of the Preferences will be 
applied on the WORKSHEET.  
When "Cancel" is clicked, the settings after the last “Apply” will be 
discarded.  (These changes have no influence on the WORKSHEET.)  

NOTE:  You cannot restore the change(s) already applied to the 
WORKSHEET by clicking “Cancel.”  In order to restore the change(s) 
on the WORKSHEET, reset the Preferences and press "Apply."  

TIPS:  We recommend you to verify your change(s) on the WORKSHEET 
by clicking "Apply" before closing the Preferences window by clicking 
"Close."  
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The first choice of Units or Defocus sign is used in the calculation program.  
The data specified in other units will be converted by the graphical user 
interface (GUI).��

�

1. Units 
Length: Angstrom�nm 
Fourier space: s�d* 
Beam convergence angle:  s�d*�mrad 
Defocus sign (underfocus): plus, minus 

1 2 

3 

4 5 

6 
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2. Crystal setting  

I (a, b, c) 
 
 
 
 
 

II… Axes are permutated as indicated 
3. Half-tone output settings 

Level settings for character-base half-tone output (11 levels)  
4. Dynamical calculation 

Range: Radius of Fourier space to be included in the calculation 
Slice thickness (cell numbers): to be used for the projection approximation 

5. Numerical data output format 
Field width: Number of characters including blank(s) 
Blank lines: number of line feed(s)�

6. Atomic Scattering Factor 
When you want to include TDS absorption using Weikenmeier-Kohl scattering 
factor, you have to specify a thermal factor (Debye-Waller factor) for each atom as 
an atom parameter. 
Doyle-Turner scattering factor can be used up to only s=2.0 (d*=4.0) due to its 
approximation. 

 
 

Creating Your Template WORKSHEET 
Graphical user interface (GUI) uses a WORKSHEET for data preparation.   
xHREM is shipped with WORKSHEETs (Default.WS1 etc.), on which 
some standard values are already specified.  We call these WORKSHEETs 
having standard values as "Default (Template)."  When you create a new 
data, you can save your trouble to input these common data at each time by 
using the Default WORKSHEET.  

Moreover, you can prepare the data with less effort by using the 
WORKSHEET tailored for your experimental conditions.  For examples, 
an acceleration voltage, an output range for dynamical scattering amplitudes 
etc. for the scattering calculation, or a spherical aberration coefficient, a 
defocus spread, a bean convergence angle, an aperture radius etc. for the 
image intensity calculation.  You can create a template WORKSHEET 
with other preferential settings.��

Creating a template WORKSHEET will follow the same steps as preparing 

Entrance surface a 

b 

c 
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the new data.  However, only default data items are specified instead of 
filling out all entries.  

To create a new data from a scratch, do this:��
1. Launch a graphical user interface (GUI) for which you want to create a 

template. 
2. Select "Default" from the file selection dialog. 
3. Specify default data items. 
4. Save your WORKSHEET with a specific name, which reminds you that it is a 

template data. 
From next time, you can start with your template saved above and save 
your trouble by using these predefined data items. 
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! MultiGUI Reference  
WORKSHEET 

�

1. Title (max. 82 characters) 
Type a sample name, composition, and experimental conditions etc. as 
you want.  

2. Cell Parameters 

1 
2 3 

4 

5 

6 

7 

8 

9 

10 

11 

12 

13 

14 

15 
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Specify cell lengths and angles.  The cell lengths can be given 
Angstrom or nm according to your preference.  The angles can be 
given in degree or cosine of the angle.  A mixed input of angle in 
degree or cosine is not allowed.  (Input in angle is recommended.) 

3. Symmetry Operation 
You can specify symmetry operations by selection one of the space 
groups by clicking "Select" or edit them by clicking "Edit."  

"Select" button: 
Clicking the "Select" button will open the following window showing 
all possible space groups.  Select one of the space groups 
corresponding to your specimen.  The space group you have selected 
will appear in the box.  

 
You can see symmetry elements in the window (see "Edit" button 
below) appeared by clicking the "View" button.  Please confirm the 
symmetry elements are correct before proceeding the calculation.  

"Elements": Number of symmetry elements  

"Edit" button: 
Clicking the "Edit" button opens a window where you can specify 
arbitrary symmetry operations. 
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Symmetry operations should be specified according to the conventions 
used in International Tables for Crystallography. 

" xyz components of each symmetry operation should be separated by a 
comma (,)  

" Each symmetry element should be separated by a semicolon (;) 
" Symmetry list should end with a period (.)  

4. Atom Parameters 
Atom parameters will be imported from a data file by choosing 
"Import" or compiled in the window that will appear by choosing 
"Edit." 

"Import" button:  
Clicking the "Import" button will open the window to select an existing 
atom parameter file. 
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" Data Base: atom parameters already saved by MultiGUI� 
" Text Data: atom parameters saved in the text format.  

Data Separator: space(s) or comma can be used as a data separator 
Convert Physical Scale to Fraction: atomic parameters (coordinates) 
specified in a physical unit (nm or A) can be converted to a crystal 
lattice unit. This may be useful to read the model data created by a 
third-party model building software.  
Parameter Sequence: the order of data items will be specified. If there is 
no corresponding data item in the file, you may use "None" to skip 
reading it. 
Data file will be selected in the dialog that appears by clicking the 
"Select" button. 
When the atom parameters are imported successfully, these parameters 
will be displayed in the window (see "Edit" button below).  

No of Atoms: number of input atoms 

"Edit" button:��
Clicking the "Edit" button opens a window where you can compile 
atom parameters on the spot. 

 
" No: sequence number added automatically 
" Name: atom name including element name. Ex. Ag, C(1), O-2 
" x, y, z: atom position in the unit cell defined by a fraction 
" Occupancy: ratio of occurrence of atom (normally, one).  This 
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parameter may be omitted.  
" Thermal: isotropic thermal displacement factor. If you input zero (or 

leave blank), then the Overall Thermal Factor (see the next parameter) 
will be applied in the calculation.  

Overall Thermal Factor:  
Isotropic thermal displacement factor that will be applied for each atom 
in the crystal. If the thermal displacement factor of each atom is 
specified as zero or left blank, this thermal displacement will be used 
for that atom in the calculation. 

Calculation Control 
5. Phase Grating Setup 

# On/off phase grating calculation  
Dividing-a-cell-into box: Select a number of divisions of unit cell (up to 
thousand (1000)). The phase grating number up to 10 can be selected 
from the pull-down list. If you want to use more than 10 phase gratings, 
simply input a number (up to 1000) of phase gratings to an editable box 
above the drop-down list.  

6. Multislice Calculation 
# On/off multislice calculation��
Until box: set the last slice number (up to 9,999) 
New & Append buttons: select "New" when you start calculation, or 
"Append" when you continue calculation by increasing the last slice 
number.  
PG Sequence buttons: A default phase grating sequence is a cyclic 
repetition of zero (0) to the maximum number of phase grating. You 
can edit the sequence using the following Sequence Editor, which will 
appear by clocking the “PG Sequence” button. 

 
The phase grating sequence to be used will be specified by the phase 
grating numbers separated by a space(s). 

7. Acc. Voltage 
8. Incident Beam Direction 
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Specify an incident beam direction in term of a real lattice coordinates.  
Ex: [001] incidence. 

9. Unitary Test: Test for the sum of scattering intensity  
Limit: Lower limit of the total intensity. A number close to one imposes 
a strict condition. 
Cycle: Frequency for the test in terms of slice number 

Output Control 
10. Dynamical Structure Factor 

Range: File output range (radius) of scattering amplitudes 
Cycle: Frequency for the file output in terms of slice number  

11. Potential Distribution 
# On/off numerical map output  
# On/off halt-tone map output 
# On/off file output for gray scale display  

12. Wave Function 
# On/off numerical map output 
# On/off file output for gray scale display 
Cycle: Frequency for the file output in terms of slice number 

13. Numerical Map 
Vertical and horizontal ranges and steps for numerical map output  

14. Half-tine Map 
Vertical and horizontal ranges and scale for half-tone output 

TIPS: The half-tone map will be suppressed by setting the “11. Potantial 
Distribution” control.  
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! ImageGUI Reference
WORKSHEET 
 

 

1 
2 

3 
4 

8 

9 
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6 
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1. Title (max. 82 characters) 
Type a sample name, composition, and experimental conditions etc. as 
you want. 

2. Optical Parameters 
" Spherical aberration coefficient (C3) 
" Fifth order Spherical aberration (C5) 
" Defocus spread 
" Beam convergence 
" Aperture radius: inner and outer 
           position 
" Zernike Phase Plate 

Specified phase shift will be applied in the area inside of the inner 
aperture. If the phase shift is zero, the beam within the inner aperture is 
blocked.  

3. Simulation Mode 
Partial coherency will be treated by First order (Envelope) 
approximation or Second order (TCC) approximation.  

4. Slice thicknesses 
Specimen thickness at which EM images will be calculated will be 
given in terms of slice number (up to 10 slices). 

5. Defocus values 
Defocus values at which EM images will be calculated will be specified 
(up to 20 values).  Sign and unit of defocus will be changed by 
Preferences settings.  

Output Control 
6. Microscope Images 

# On/off numerical map output 
# On/off file output for gray scale display 
# On/off half-tine output 

# On/off contrast reversal  
# On/Off normalization  

7. Structure Factor 
If you select this option, structure factors will be listed before image 
calculations for each lice data.  

8. Numerical Map 
Vertical and horizontal ranges and steps for numerical map output 

9. Half-tone Map 
Vertical and horizontal ranges and scale for half-tone output 
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!  DFOutGUI Reference
WORKSHEET 

�

 
 
 
 

1. Numerical Output 
If you select this option, amplitudes and phases of specified reflection 
indexes will be listed at specified thickness (slice).  
The scale of amplitude will be selected from " Normalized" or 
"Kinematical scale." 

2. Graphical Output 
If you select this option, amplitudes and phases vs. thickness will be 
displayed graphically for specified reflection indexes.  
The amplitude will be displayed in log scale. 

3. Export Data for Graphical Application 
If you select this option, amplitudes and phases data will be output as 
text files, which can be used by a spreadsheet (graph) application.  

1 

2 

3 

4 

5 
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4. Output Range 
Thickness for a list and/or graph output will be specified by its range 
and step in slice unit. 

5. Indices of Reflections 
Indexes of reflections you want to check will be specified in a column 
(up to 9 reflections).  Reflections in each column will be displayed 
graphically in the same page (up to 10 pages).  
Reflection indexes should be specified by a two-dimensional index in a 
(projected) diffraction pattern. 
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! ImageBMP Reference
WORKSHEET 

�

For EM Image Intensity Data 

 
 

The title of the data and its projected two-dimensional cells (and the number 
of sampling points) will be shown at the top part of the window. 

 
For Data from Dynamical Scattering Calculation 
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xHREM Userʼs Guide 52 

For EM Image Intensity Data 
1. Display Range 

The range of display will be defined in terms of unit cell.  

2. Scale (pixel/Angstrom) 
The scale will be specified by a number of pixels per Angstrom.  Total 
numbers of pixels (Height and Width) to be displayed will be shown 
estimated according to the scale.   

3. Image Selection 
" Slice 

The specimen thickness (slice number) for an EM image to be 
displayed will be selected from the slice list.  When you select "All", 
images for all slices in the list will be generated one by one.  When 
you choose “Select”, a dialog where you can select individual image 
will appear.  

" Defocus 
The defocus value for an EM image to be displayed will be selected 
from the defocus list.  When you select "All", images for all defocus 
values in the list will be generated one by one.  When you choose 
“Select”, a dialog where you can select individual image will appear. 

NOTE:  In this utility an under-focus value is always positive irrespective of 
your defocus sign selection in the "Preferences." 

" Image Tableau (Table Layout) 
This will control the way of display of selected images.  When 
checked, the selected images will be displayed in a table layout.  
Otherwise, each selected images will de displayed separately.  When 
you click “Options” button, a dialog to setup a layout will be opened. 
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4. Survey 
Clicking "Survey" will open a small window showing a display range 
(Maximum and minimum values). 

 
You can change the display ranges by setting numbers in the boxes.  

5. Reverse Contrast 
When checked, the image will be displayed with a reversed contrast. 

6. Atom Overlay 
When checked, a colored circle will be drawn on each atom position.  
The size and color of circle for each element will be changed in the 
dialog that will appear when you click “Setup” button.  

 
7. Generate 

Gray scale image will be generated by clicking "Generate." 
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For Data from Dynamical Scattering Calculation 
In the selection you can choose either "Potential" of "Wave Function" to be 
displayed as a gray scale image. 
" Potential 

The phase grating number (slice number) for which a potential 
distribution is displayed will be selected from the phase grating list.  
When you select "All", the potential distributions for all phase gratings 
in the list will be generated one by one.  When you select "Projection", 
an image obtained by summing the potentials over all slices will be 
displayed. 

" Wave Function 
The specimen thickness (slice number) at which a wave function is 
displayed will be selected from the slice list.  When you select "All", 
images of all wave functions in the list will be generated one by one. 

" Show 
As the potential and wave-function are saved in complex number, you 
have to choose a quantity to be displayed as a gray scale image from a 
following list: 

ImageBMP Menu 
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! SpotBMP Reference
WORKSHEET 

 

  
 

The title of the data and its projected two-dimensional cells (and the number 
of sampling points) will be shown at the top part of the window. 

 
 

１． Display Range 
" Radius 

The diffraction area to be displayed will be specified by its radius (in 
1/Angstrom) from the center.  The displayable area that is outputted by 
the dynamical calculation program is indicated below the box.  

" Resolution 
The resolution will be specified by a number of pixels per 1/Angstrom.  
An image size to be displayed will be shown estimated according to the 
resolution. 

２． Display setup 

1 

2 

3 
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" Type 

 
Display data type will be selected from the following list:  

" Show Index 
On/off the reflection index display on the gray scale image  

" Spot shape 
You can choose a display shape of reflection spots from either "Dusk" 
or "Peak." 

" Spot radius 
Size of each diffraction spot in pixels.  

" Background Color 
"White" background displays an image like a negative, and "Black" 
background emulates an output on a printing paper.  

３． Survey 
Clicking "Survey" will open a small window showing a display range 
(Maximum and minimum values). 

 
You can change the display ranges by setting numbers in the boxes. 

４． Slice 
The specimen thickness (slice number) at which a diffraction pattern is 
displayed will be selected from the slice list.  When you select "All", 
images of all diffraction patterns in the list will be generated one by 
one. 

５． Reverse Contrast 
When checked, the image will be displayed with a reversed contrast. 
 

６． Generate 
Gray scale image will be generated by clicking "Generate." 

�

�
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SpotBMP Menu

�



 

xHREM Userʼs Guide 58 

! Blank WORKSHEET        Appendix 

MultiGUI
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ImageGUI
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DFOutGUI
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FAQ 
Frequently Asked Questions 

 
This chapter will answer to 
Frequently Asked Questions 

with Q&A style 
 
 
 
Dynamical Scattering Calculation（MultiGUI） 
Q001: How to use Atom Parameter Editor? 
Q002: How to use ”Occupancy”? 
Q003: I saw the example, where an angle of lattice parameter is zero (o)… 
Q004: How many phase gratings can we use? 
Q005: How many slices can we divide a unit cell (or a super-cell) into? 
Q006: How is a phase grating (transmission function) evaluated? 
Q007: How to specify the range of scattered waves to be included in the multislice 
calculation? 
Q008: What is a slice thickness for [011] or [111] incidence? 
Q009: How to specify an incident beam direction? 
Q010: Why is the incident beam direction with c=0 not allowed? 
Q011: How to treat an incident beam direction with c=0? 
Q012: How is an atom scattering factor for electrons calculated? 
Q013: Can we use scatter factor for ions? 
Q014: How to specify a thermal factor (thermal vibration effect)? 
Q015: How does thermal factor affect an atomic scattering factor? 
Q016: How do we use “Unitary test”? 
Q017: What kind of propagation function is used in calculation? 
Q018: What is three-dimensional effect? 
Q019: How to include three-dimensional effect in multislice calculation? 
Q020: How to specify model symmetry (symmetry operations)? 
Q021: I canʼt read atom parameters from a text file. 
Q022: How to create an atom parameter file (text data)? 
Q023: What is a format of atom parameter file (test data)? 
Q024: How does an atomic potential contribute to a projected potential? 
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Image Calculation（ImageGUI） 
Q101: My image does not show any contrast. 
Q102: Let me know the differences between Simulation Modes. 
Q103: When I select “First Order (Envelope)” from Simulation Mode, I can get a correct 
image, but not with “Second order (TCC)”. 
 
Dynamical Scattering Amplitude Output（DFOutGUI） 
Q201: Why is a reflection specified using only two indexes? How can we relate these 
indexes to a normal three-index system? 
Q202: How is the phase displayed? 
 
CBED Extension 
Q301: High angle area is not displayed. 
Q302: Does HOLZ lines appear under the projection approximation? 
Q303: Can we calculate a Large-angle CBED (LACBED, Tanaka pattern)? 
Q304: How can we improve HOLZ line accuracy? 
 
STEM Extension 
Q401: An output from STEM image does not seem to represent a model structure 
Q402: How to select a super-cell size? 
Q403: Computation becomes extremely slow, when a model size becomes large. 
Q404: What is a range to be included for scattering calculation? Does this range 
depend on the model size? 
Q405: What is a strategy to shorten computation time? 
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Dynamical Scattering Calculation（MultiGUI） 
 

Q001 How to use Atom Parameter Editor? 

  

A 1. Click “Edit” button from Atom Parameters pane. Then, the following “Atom 
Parameter Editor” window will appear. In this example, the parameters for 
two atoms are already registered. 

�

2. Input the following parameters for each atom in separate row. 
! “Name”: Atom identifier including an element name. You can add 

figure(s) before or after the element name to identify each atom. 
! “x”, “y” and “z”: Atom positions in terms of a unit cell length. 
! “Occupancy”: Average probability of occupying the site (normally one). 
! “Thermal”: Thermal parameter, namely Debye-Waller factor. If this 

parameter is zero (0), “Overall Thermal Factor” will be used.  

3. When you finish entering the parameters for all the atoms, click “OK” to 
save the data and close the window. You can click “Cancel” to abort an input 
at any time.  

NOTE  You can save atom parameters as a text file by clicking “Export.” Then, 
you can edit its content easily using your favorite text editor. You can import atom 
parameters in a text file using “Import” in the “Atom Parameters” pane of MultiGUI. 
Please check also Q023. 

 

Q002 How to use ”Occupancy”? 

  

A “Occupancy” is a probability, with which the element occupy the site as an 
average over many unit cells. Since each element cannot occupy the site in 
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fraction, occupancy is normally one (1). However, in a disordered structure, for 
example, a specific site will be occupied more than one element, and an occupancy 
of each element becomes less than one,  

For a special atom position, the symmetry operation generates an atom at the 
original atom position. “Multiplicity” (the total number of symmetry-generated 
atoms at the same position) is automatically taken into account by xHREM, so you 
may not necessary to set “Occupancy” to 1/“Multiplicity” as sometime required by 
other software. 

 

Q003 I saw the example, where an angle of lattice parameter is zero (o)… 

  

A You can specify an angle in terms of cosine. Thus, zero means 90 degree. 
However, you should not mix a degree and cosine, so a mixed set of three angles, 
say 0, 0, 120 are not acceptable. 

TIPS Cosine of the angle is used inside the program. 
 

Q004 How many phase gratings can we use?  

  

A You can use up to 1000 different phase gratings. The sequence of the phase 
grating to be used in calculation will be easily is specified by using “PG Sequence 
Editor”. 

 

Q005 
How many slices can we divide a unit cell (or a super-cell) into? 

  

A Since the maximum different phase grating is 1000, you can divide the unit cell 
(your model structure) into 1000 slices. 

 

Q006 
How is a phase grating (transmission function) evaluated?  

  

A A phase grating is directly evaluated by assigning a projected potential of the slice 
to a complex exponential function. Here, the direction of potential projection is not 
perpendicular to the slice, but along the incident beam direction.�

 

Q007 How to specify the range of scattered waves to be included in the multislice 
calculation? 

  

A The range of scattered waves included in the multislice iteration is specified by 
“Range” parameter of “Dynamical Calculation” pane of the Preferences window.�
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Q008 What is a slice thickness for [011] or [111] incidence?  

  

A Normally, the slice thickness is measured perpendicular to the slice (this is a 
physical thickness of the slice). However, the length of a slice measured along the 
incident beam direction is more important from electron scattering point of view. 

For example, the scattering conditions are different even for the same incident 
beam direction of [011], when the incident surfaces is (001) or (011). xHREM can 
handle such differences. 

xHREM uses the slice that is always parallel to the entrance surface, but projects 
the potential along the incident beam direction. 

If you are interested in knowing more details, please consult the paper:��
K. Ishizuka, Acta Cryst. A38 (1982) 773-779.�

 

Q009 How to specify an incident beam direction?  

  

A An incident beam direction t is specified by three unit cell vectors in the real space 
as follows: 

! 

t = d1a + d2b + d3c  

For example, the incident beam direction parallel to c-axis is defined as [0, 0, 1]. If 
the incident beam direction is not specified by a simple sum of three unit cell 
vectors, it is not a good condition to take an EM image. 

NOTE  In an experiment of electron diffraction, the incident beam direction may 
be specified by the Laue point, which corresponds to the Ewald sphere center 
projected on the observation diffraction plane. 
TIPS  Given the incident beam directions specified in real and reciprocal unit cell 

t = d1a + d2b + d3c
= r1a

* + r2b
* + r3c

*  

each coefficient can be easily evaluated as follows: 

! 

d1 = ta* = r1a
*2 + r2b

*a* + r3c
*a*

r1 = ta = d1a
2 + d2ba + d3ca

�

 

Q010 Why is the incident beam direction with c=0 not allowed?  

  

A xHREM assumes that an incident surface is the (001) plane (the c-plane of an 
input unit cell). Thus, the incident beam direction with c=0 means that the electron 
beam is parallel to an entrance surface, which is not occurred in practice.  

TIPS  You can specify an incident surface of the specimen, on which an electron 
beam impinges. Therefore, using xHREM it may become possible to treat a 
surface effect that is usually neglected by other programs. 
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Q011 How to treat an incident beam direction with c=0?  

  

A An incident beam direction with c=0 in terms of an input unit cell is not accepted 
(see Q010). To handle this problem, you can transform the coordinate system from 
“Preferences” dialog under Edit menu, and make the entrance surface include the 
c-axis.   

MultiGUI takes care of all the necessary transformations, such as atomic 
coordinates, symmetry operations, an incident beam direction and so on, and 
creates a correct data set for calculation.�

 

Q012 How is an atom scattering factor for electrons calculated?  

  

A Atom scattering factor (ASF) can be chosen from the following two types in the 
“Atom Scattering Factor” pane of “Preferences”. 

Doyle-Turner: ASF for electrons is calculated from x-ray ASF using the following 
Mott’s formula: 

fe s( ) = 0.023934 Z ! fx s( ){ } s2 ; s = sin" #  
Here, x-ray ASF is approximated by a sum of Gaussians, whose coefficients are 
tabulated in International Tables for x-ray Crystallography, Vol. IV. It should be 
noted that Doyle-Turner ASF is valid only up to s=2.0. 

Weikenmeier-Kohl: This form factor is valid also for high-angle scattering beyond 
s=2.0. Thus, this form factor can be used to estimate absorption potential due to 
thermal diffuse scattering (TDS). �

 

Q013 Can we use scatter factor for ions?  

  

A In principle, the answer is YES. However, the current GUI does not support such 
cases, and you have to modify manually the data (.DA1) created by MultuGUI. 
Please contact our user support for detailed steps. �

 

Q014 
How to specify a thermal factor (thermal vibration effect)?  

  

A Effect of thermal vibration is taken into account by using a Debye-Waller thermal 
factor. 

! When you want to use a different thermal factor to each atom, you can 
specify each thermal factor at “Thermal” column of atom parameters. 

! When “Thermal” parameter of individual atom is zero, the thermal factor 
specified at “Overall Thermal Factor” will be applied to that atom,  

TIPS  For simplicity, you may want to use the same thermal factor for all the 
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atoms in the model. In this case, specify the thermal factor in “Overall Thermal 
Factor” and leave blank (or set to zero) at “Thermal” column of each atom. 

 

Q015 How does thermal factor affect an atomic scattering factor?  

  

A An atomic scattering factor (ASF) is attenuated by a Debye-Waller thermal factor 
B as a function of a scattering angle 
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You may note that high-angle scattering is more affected by thermal vibration than 
low-angle scattering. �

 

Q016 How do we use “Unitary test”?  

  

A Without absorption there is no decrease of electrons. Thus, the total sum of 
electron density distribution or electron diffraction distribution is always constant. 
However, if an enough scattering area is not included in scattering calculation, 
some electrons tends to scatter outside of the scattering area, and the total sum of 
diffracted electrons will decrease with a sample thickness. Therefore, Australian 
group introduced the Unitary Test to check calculation conditions for their 
reciprocal-space multislice formula. 

However, xHREM uses the multislice formula (in mixed-space) based on Fast 
Fourier Transform (FFT), and thus the total sums of both electron density 
distribution and electron diffraction distribution are identical, and always equal to 
unity.  Therefore, a usual way of Unitary Test has no meaning. 

The Unitary Test of xHREM calculates the total sum of electron diffraction 
distribution excluding intensities at the outermost pixels. Therefore, if an enough 
scattering area is not included in scattering calculation, the total sum of scattering 
distribution will decrease with a sample thickness. However, since this attenuation 
is mild, the Limit of Unitary Test should be very close to one to make the test 
effective.  

NOTE  When you include absorption due to thermal diffuse scattering (TDS) 
using Weikenmeier-Kohl atomic scattering factors, a number of electrons will 
actually decrease due to absorption. Thus, if you donʼt set the Unitary Test limit 
sufficiently low, a computation will stop in the middle of multislice iteration 
(scattering calculation) owing to the Unitary Test. 

 

Q017 What kind of propagation function is used in calculation?  

  

A xHREM uses the propagation function that corresponds to a spherical wave, not a 
propagation function with parabola approximation. If you are interested in 
knowing more details, please consult the paper: K. Ishizuka, Acta Cryst. A38 
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(1982) 773-779.  
 

Q018 What is three-dimensional effect?  

  

A Three-dimensional effect is such that relative atom positions along the incident 
direction of an electron beam affect scattering intensity distribution, �

 

Q019 How to include three-dimensional effect in multislice calculation?  

  

A Three-dimensional effect may be included in multislice calculation, when relative 
atom positions along the incident direction of an electron beam are taken into 
account by dividing a unit cell (model structure) into a multiple slices. 

NOTE  How accurate the multislice formulation can take into account a 
three-dimensional effect is still an open question. 

 

Q020 How to specify model symmetry (symmetry operations)?  

A The way to specify symmetry operations follows the rule used in International 
Tables for Crystallography. 

! yxz components of symmetry operation will be separated by a comma (,). 
! each symmetry operation will be separated by a semicolon (;). 
! end of all the symmetry operation is a period (.). 

Example:  
x, y, z; y, x, z+1/2.�

 

Q021 I canʼt read atom parameters from a text file.  

  

A Please make sure that you are specifying parameter entries in a correct order.��

 

Q022 How to create an atom parameter file (text data)?  

  

A Input a name, coordinates (x, y, z), occupancy and thermal factor for each atom in 
a single line using an editor or a word� processor.  A serial number can be added 
at the beginning of each line. Each parameter will be separated by a comma (,) or 
any number of spaces (blanks). Thus, you don’t need to align the column position 
of each parameter.  

Example 
Name      X        Y        X    Occupancy  Thermal 

Sn1       0        0        0        1.0        0    
O1        0.307    0.307    0        1.0        0 
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NOTE  Name should include an element name. You can add a number to the 
element name to distinguish different atoms of the same element. 

Save a created data to a text file (sample-name.atm). �

 

Q023 What is a format of atom parameter file (test data)?  

  

A Atom parameter file is a text file, each line of which contains a name, coordinates 
(x, y, z), occupancy and thermal factor. A number can be added at the beginning of 
each line. Each parameter will be separated by a comma (,) or any number of 
spaces (blanks). Thus, you don’t need to align the column position of each 
parameter.  

The order of parameters in the text file may be arbitrary, since the order of 
parameters can be specified as shown below, when you read them.  

 
When atom coordinates are defined in a physical unit (nm or A), you can change 
the parameters in a lattice unit by using “Convert Physical Scale to Fraction.” This 
function is especially useful, when you create a atomic model using a third-party 
model building application.�

 

Q024 How does an atomic potential contribute to a projected potential?  

A When a whole unit cell is treated as a single slice (projection approximation), a 
whole atomic potential will be projected. 

When a unit cell is divided into a multiple slices, in principle, only the part of 
potential belongs to a slice should be projected. However, xHREM will project the 
whole atomic potential to the slice, which the center of atom (atom coordinate) 
belongs to. In this way, we can use the projection theorem of Fourier transform to 
efficiently project an atom potential. 
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Image Calculation（ImageGUI） 
 

Q101 My image does not show any contrast.  

  

A Please check an aperture radius for image calculation. The smallest fringe spacing 
that will contribute to image formation depends on the unit (s or d*), which you 
can select from “Preferences” window. (Note: 2s = d*) 

� � The smallest fringe spacing = 1/2s = 1/d*  

Especially, when you have forbidden reflections, please check whether allowed 
reflections are included within the aperture.�

 

Q102 Let me know the differences between Simulation Modes.  

  

A Simulation Mode determines the way to treat partial coherence. 

Using xHREM you can choose a commonly used technique using Envelope 
functions, or a more elaborate technique using Transmission Cross-coefficient 
(TCC). 

The technique using TCC, except a small model, requires more computation time 
than the technique using Envelope functions.�

 

Q103 When I select “First Order (Envelope)” from Simulation Mode, I can get a correct 
image, but not with “Second order (TCC)”.  

  

A In the case of “Second order (TCC)” the spatial frequencies of twice of the 
objective aperture radius will be included in image calculation. This is because 
interference terms between scattered waves that pass the objective aperture should 
be included in image calculation. 

Thus, “Second order (TCC)” calculation requires the Fourier space that is twice of 
the aperture size, although “First Order (Envelope)” calculation requires the 
Fourier space that corresponds to the aperture size. Here, image calculation uses 
the same area (the same size of Fourier space) used by scattering calculation. 

When the Fourier space used for image calculation is not enough, “Range” 
parameter of “Dynamical calculation” pane should be increased from the 
“Preferences” window of MultiGUI, and scattering calculation should be done 
again. The Fourier space used for image calculation cannot be modified by 
changing “Range” from the “Preferences” window of ImageGUI. 

Note  Except you donʼt specify an exceptionally small “Range” for scattering 
calculation, this situation will not occur.  
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Dynamical Scattering Amplitude Output（DFOutGUI） 
 

Q201 Why is a reflection specified using only two indexes? How can we relate these 
indexes to a normal three-index system?  

  

A Multislice calculation determines scattering amplitudes using two-dimensional 
slices (Phase Gratings). Thus, a wave function calculated is two-dimensional, and 
its Fourier transform is also two-dimensional. The two indexes specifies a 
reflection in 2D reciprocal space.  

This 2D index can be converted to a normal 3D index by finding a relation 
between the 3D reciprocal lattice and the 2D reciprocal lattice. The same 
technique can be used to find a relation for Higher Order Laue Zone (HOLZ).  

 

Q202 How is the phase displayed?  

  

A All the phases are shifted by 

! 

"# 2, and thus the phase of scattered wave from a 
thin sample corresponds to the phase of crystallographic structure factor (the phase 
of the incident wave is displayed as 

! 

"# 2).  

In crystallography the phase of structure factor is zero or 

! 

"  for the structure that 
has a center of symmetry (Namely, the structure factor is real, and will be positive 
or negative value). xHREM makes the phase of scattered wave from a thin sample 
correspond to the phase of crystallographic structure factor.  
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CBED Extension 
 

Q301 High angle area is not displayed.  

  

A The output range of CBED pattern is specified by “Range” of “Dynamical 
Structure Factor” in “Output Control” pane. Please check the unit (s ot d*) and the 
specified output value.  

 

Q302 Does HOLZ lines appear under the projection approximation?  
 

  

A Yes, HOLZ lines will appear close to the correct positions even under the 
projection approximation. However, their intensities may not be accurate.  

 

Q303 Can we calculate a Large-angle CBED (LACBED, Tanaka pattern)?  

  

A In LACBED experiment, a sample is placed off the electron beam focus point. 
Then, only the transmitted beam selected by an aperture is recorded. 

Since xHREM calculates a CBED pattern by creating the focused probe at the 
specimen entrance surface, LACBED cannot be obtained.  

 

Q304 How can we improve HOLZ line accuracy?  

  

A In order to get a fine HOLZ line, use a higher “Resolution” of “Calculation 
Control” of the CBED dialog. Please consult the CBED Manual for a calculation 
step for each resolution setting. 

In order to obtain a CBED pattern with an accurate position and intensity of 
HOLZ lines, the 3D effect (see Q019) should be properly included. Thus, a unit 
cell should be divided into a multiple slices. 
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STEM Extension 
 

Q401 An output from STEM image does not seem to represent a model structure.  

  

A At first, check a projected model structure using Model Viewer (Model View of 
MultiGUI). If the projected model is displayed correctly, then check a scan step. If 
the scan step is larger than 0.3 A, you may not get a smoothed atomic structure. 

NOTE: If a displayed projected model structure is not correct, even when input 
atom parameters and a selected space group are right, then the symmetry 
operations of the selected space group may be wrong. If you find such an error, 
please report your finding to our support. 

 

Q402 How to select a super-cell size?  

  

A The size of a super-cell determines a sampling interval of Fourier space (an 
inverse of super-cell size corresponds to a calculation step of scattering 
distribution). Therefore, a super-cell size of larger than 5 nm (scattering 
calculation step of less than 0.2 /nm) should be employed for a good simulation.  

1. Crystal model 

If a unit cell of the model is less than 5 nm, select “Standard” from “Super-cell 
size.” Then, the input unit cell will be automatically repeated to create an 
approximately 5-nm super-cell. If a unit cell of the model is larger than 5 nm, 
select a size of super-cell larger than the unit cell. 

2. Interface or a defect model 

Select an appropriate size of super-cell that is larger than the longer edge of the 
structure model. Other short direction will be automatically repeated to fill the 
selected super-cell.  

3. Model with no periodicity, such as a nano-particle  

Select an appropriate size of super-cell that can accommodate the whole model. 

 

Q403 Computation becomes extremely slow, when a model size becomes large.  

  

A STEM calculation requires all the phase gratings at each scan point. Therefore, 
even when a part of phase gratings cannot be loaded into the mail memory (RAM), 
all the phase gratings should be read from an external memory for each scan points 
in the case of a large model. Since computation speed of a contemporary PC is 
astonishingly fast, a total computation time will be extremely deteriorated due to 
this data access. 

To avoid this defect you have to install more RAM. If the total size of phase 
gratings becomes more than about 2GM, you may have to use the 64-bit version 
(STEM Extension Pro) that supports a 64-bit OS to handle more memory. 
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Q404 What is a range to be included for scattering calculation? Does this range depend 
on the model size?  

  

A In order to evaluate probe propagation under elastic scattering, calculation 
including s=2.5/A (d*=5.0/A) is normally sufficient. This range does not depend 
on the model size.   

 

Q405 What is a strategy to shorten computation time?  

  

A Since STEM simulation requires scattering calculation at each scan point, a total 
computation time tends to become very long. The current version of STEM 
Extension supports Multi-CPU (core). Thus, if you use a PC with a multi-CPU, 
you can reduce a total computation time by a factor that is approximately a 
number of CPU (Core). 

A further reduction of computation time will be obtained, if you use a cluster 
version (STEM Extension Cluster) that uses multiple computers simultaneously. 

 
 


